Prerequisites for the installation of DamageProfiler

Operating System Support

DamageProfiler has been implemented as a platform-independent tool and can thus be installed and run on Linux, Windows and MacOS. A Java 8+ platform has to be installed on the workstation used for running the tool.

Linux

It has been successfully tested on different flavors of Linux based operating systems, including ArchLinux and Ubuntu 17.04.

Windows

The application can be run on Windows 10.

Software Requirements for DamageProfiler

Install a suitable Java 8 runtime environment. We tested both Oracle Java 8 SE and OpenJRE 8 on Linux. The latter requires to install JavaFX in addition, whether the Oracle JRE already ships with the required JavaFX libraries.